Firefox 7.0.1 on mac breaks extension

 
    • kmullin schrieb...
    • Benutzer
    • 6. Okt. 2011, 6:06

    Firefox 7.0.1 on mac breaks extension

    Hi.

    I updated to Firefox 7.0.1 for macs, and it disables this extension claiming that the extension is incompatible.

    Just letting you know.

    • niq77174 schrieb...
    • Benutzer
    • 6. Okt. 2011, 15:39
    I get the same thing on FF7 for Windows ... I hope the plugin can catch back up!

    • trevdiggy schrieb...
    • Benutzer
    • 12. Okt. 2011, 22:53

    Workaround for Firefox version compatibility

    If you want your LastFM Firefox extension to work on Firefox 7.0.1 (like me), you may follow these steps to cause Firefox to skip the version compatibility check. (I did this today and I'm scrobbling again just fine.)

    1. In the Firefox address bar, go to about:config (click through any warnings about voiding your warranty).
    2. Right-click anywhere in the list of preferences and choose New > Boolean.
    3. Name the new preference "extensions.checkCompatibility.7.0"
    4. Set the value to false.
    5. Reload Firefox and reinstall the LastFM Firefox extension. *

    WARNING: This preference will skip the version compatibility check for ALL extensions, not just LastFM. You may want to flip this value to true before you upgrade to a newer version in the Firefox 7.0.* lineage to make sure all your extensions stay compatible.

    * I reinstalled because I had removed the extension. It's possible you don't need to reinstall if it's only been disabled due to incompatibility.

    I don't know for sure, but I suspect we should be able to do something similar for versions 8, 9, etc. in the future by simply adding another preference.

    • [Gelöschter Benutzer] schrieb...
    • Benutzer
    • 18. Okt. 2011, 15:03
    @trevdiggy works, thanks for the fix

    • sarajill schrieb...
    • Abonnent
    • 18. Okt. 2011, 22:29

    Thanks

    This workaround is working for me too. Thanks so much for posting this fix.

    • kmullin schrieb...
    • Benutzer
    • 19. Okt. 2011, 22:53

    update

    there's an updated version of the add-on as of now.

    • niq77174 schrieb...
    • Benutzer
    • 31. Okt. 2011, 14:59
    Yep, looks like it's working again!

Anonyme Benutzer dürfen keine Beiträge schreiben. Bitte log dich ein oder registriere dich, um Beiträge in den Foren schreiben zu können.